Support & Warranty

5-YEAR WARRANTY

We don't just offer good motorcycle speakers ... we offer the best!  That's why all Steel Horse Audio speaker systems include a complete 5-year warranty on all parts & components.  We hope you will enjoy your system for many years to come, but if you have an issue, relax in knowing we've got you covered....  If your system is not running correctly or you are having an issue with installation, please review the troubleshooting tips below then use our Live Chat or Contact Us page for a quick resolution.


No Sound Output or System Will Not Power On

• Most of the time when there is no sound (or the system is not turning on) it is due to the remote/switched wire connection (Orange wire on ST200 Classic, Blue/White wire on the ST400 Cruiser and Solid Blue wire on the ST600 Platinum). To confirm the system works you can connect this remote/switched wire directly to battery positive and the system should come on. If so, then you need to find a better switched power source (a source that comes on and off with the bike).

• Also check that the Positive (+) and Negative (-) wires are securely connected to the battery. These 2 wires and the above mentioned remote/switched wire must all be properly connected for the system to work, even if the amp appears to turn on.

• Check that the wires are not cut, melted or have any bare wire between the amp and speakers, battery or switched wire.

• Check that the fuse is still good, even if the amp light(s) still turn on.

Output is distorted, whining, popping or exhibiting other noise interference

• Lower the gain adjustments on the amplifier and adjust the EQ on your audio or mobile device (if equipped)

• Connect the ground wire to the closest available spot. Connect it to the frame (where paint is removed) as close to the amp and/or controller as possible. The longer the ground wire, the more chance of noise interference.

• Check where the wire goes in to the speaker housing stem that there is no exposed wire causing a short.  If so, please contact us for repair.

• If you have a whining noise through the speakers when revving the engine, please request a free noise filter.

• Check the 3.5mm to RCA cable that there are no kinks or static coming from this cable,  Wiggle it around where it is connected to the amplifier and audio device/Bluetooth controller.  If there are issues when moving the cable, request a replacement from us under warranty.

Volume is not loud enough

• Check that the gain (or fader) adjustment on the amp is turned up (but not too much to cause distortion). 

• Check that the volume on your audio or mobile device is turned up and the EQ is set properly.

• If not using Bluetooth, be sure the headphone jack is completely plugged in to the audio device. Many phone cases can prevent a complete, solid connection

• Check that the variable crossover switch is set to H or OFF (ST200 Classic) or HP or AP (ST600 Platinum)

• Check that your music (MP3) files are of good quality (128+) and recorded at the proper volume

• Streaming services such as Pandora and Spotify can produce a lower output and clarity if there is poor signal strength. In these cases, try using onboard music player.

• On the 4 speaker ST600 Platinum system, be sure the switch on the amp is set to 2CH. (2-channel) -- this is the input sources - the output is still 4 channels)

Only 1 speaker works

If you only have output from one speaker, then try swapping the left and right channels on the amp. If the same speaker still does not work, then it is a bad speaker. If the other speaker stops working, then it is a bad channel on the amp. Contact us to submit a warranty claim for the appropriate part.

Amp is getting too hot or not working properly

If your amplifier is getting extremely hot but still playing fine, then this is typically within normal operation. The amplifiers are designed to dissipate heat to the outer shell and can get upwards of 150 degrees on the outer shell (still within safe operating temperature). If however the amp is extremely hot with other issues (poor sound quality, strange noises, no output, shutting off, etc), then it could be overheating and/or shorting out:

• First, check that the amp has some breathing room. It should not be wrapped in any material and should have some space around it. Next, check that there are no exposed or kinked wires that could be causing a short. Follow each wire from the amplifier to the speakers, battery, and switched source wire to ensure they are not exposed or touching the frame or other metal. An exposed wire on any part of the frame or metal could cause an overheating and/or shorting out issue with your amplifier.

• ST600 PLATINUM / ROCKFORD AMP: Does the light go red on your amp and music stop playing? This is typically due to an issue with Ohms, heat or wiring. First, make sure you are using Steel Horse Audio speakers, or if they are a different brand, be sure they are at least 4ohm stable. 2ohm or 8ohm speakers will cause damage to the amp as well as result in clipping and overheating. Make sure there is plenty of breathing room for the amp and it is not overheating. Check your wiring and ensure nothing is exposed, broken, pinched, etc. If the light is still on, contact us.

• Double check all your connections. One simple pinched wire or crushed fuse can cause overheating or other issues. On the ROCKFORD amp, be sure to also check that the black plug that connects to the amp with the ground and positive has a good solid connection and all the wires are screwed in securely. Something as small as a loose ground connection can cause numerous issues.

• Another option is to to completely remove the system from the bike and bench test it. If it only works when off the bike, then there is most likely an internal exposed wire and you should submit a warranty claim.

ST600 system turns off after 5 minutes of use

This happens if you do not connect the Bluetooth controller correctly.  The controller must be wired to the battery with the red (+) and black (-) wires, then connect the blue wire to the blue wire from amplifier. Then connect the 3.5mm to RCA cable from the amplifier to the Bluetooth controller.  Next, pair your audio device with the Bluetooth controller.  (NOTE:  When there is no source connected or music playing for more than 5 minutes, it will shut off the system due to the built in fail-safe.  This helps prevent battery drain.)